0 votes
126 views

Hi, Im using the latest version of OpenLCA with ecoinvent 3.7

the logs show an error with the Julia libs (below), any pointers are more than welcome

Regards

Edwin

31mainERRORorg.openlca.julia.JuliaFailed to load Julia libs from C:\Users\spadmin\AppData\Local\openLCA
java.lang.UnsatisfiedLinkError: Can't load library: C:\Users\spadmin\AppData\Local\openLCA\libgfortran-3.dll
     at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1827)
     at java.lang.Runtime.load0(Runtime.java:809)
     at java.lang.System.load(System.java:1086)
     at org.openlca.julia.Julia.loadFromDir(Julia.java:77)
     at org.openlca.app.App.getSolver(App.java:71)
     at org.openlca.app.rcp.RcpActivator.start(RcpActivator.java:68)
     at org.eclipse.osgi.internal.framework.BundleContextImpl$3.run(BundleContextImpl.java:842)
     at org.eclipse.osgi.internal.framework.BundleContextImpl$3.run(BundleContextImpl.java:1)
     at java.security.AccessController.doPrivileged(Native Method)
     at org.eclipse.osgi.internal.framework.BundleContextImpl.startActivator(BundleContextImpl.java:834)
     at org.eclipse.osgi.internal.framework.BundleContextImpl.start(BundleContextImpl.java:791)
     at org.eclipse.osgi.internal.framework.EquinoxBundle.startWorker0(EquinoxBundle.java:1013)
     at org.eclipse.osgi.internal.framework.EquinoxBundle$EquinoxModule.startWorker(EquinoxBundle.java:365)
     at org.eclipse.osgi.container.Module.doStart(Module.java:598)
     at org.eclipse.osgi.container.Module.start(Module.java:462)
     at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:493)
     at org.eclipse.osgi.internal.hooks.EclipseLazyStarter.postFindLocalClass(EclipseLazyStarter.java:117)
     at org.eclipse.osgi.internal.loader.classpath.ClasspathManager.findLocalClass(ClasspathManager.java:570)
     at org.eclipse.osgi.internal.loader.ModuleClassLoader.findLocalClass(ModuleClassLoader.java:330)
     at org.eclipse.osgi.internal.loader.BundleLoader.findLocalClass(BundleLoader.java:396)
     at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:474)
     at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:423)
     at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:415)
     at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:155)
     at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
     at org.eclipse.osgi.internal.framework.EquinoxBundle.loadClass(EquinoxBundle.java:620)
     at org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.createExecutableExtension(RegistryStrategyOSGI.java:196)
     at org.eclipse.core.internal.registry.ExtensionRegistry.createExecutableExtension(ExtensionRegistry.java:934)
     at org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension(ConfigurationElement.java:246)
     at org.eclipse.core.internal.registry.ConfigurationElementHandle.createExecutableExtension(ConfigurationElementHandle.java:63)
     at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:198)
     at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:137)
     at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:107)
     at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:400)
     at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:255)
     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
     at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
     at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
     at java.lang.reflect.Method.invoke(Method.java:498)
     at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:660)
     at org.eclipse.equinox.launcher.Main.basicRun(Main.java:597)
     at org.eclipse.equinox.launcher.Main.run(Main.java:1468) 
in openLCA by (120 points)

1 Answer

0 votes
by (85k points)
Hi, Julia libraries are making the calculation faster, if they are not present (haven't been downloaded yet) this is shown as error in the log file but does not lead openLCA to crash. There should be different messages in the log file that detail a crash (latest are at the bottom of the first page).
by (140 points)
I am also getting similar issue. where to download libraries?
...