+1 vote
54 views

Hello,
I have dowloaded the openLCA 1.8 project from github and use Eclipse IDE for RCP and RAP Developers, Version: 2018-12 (4.10.0) to build it

The target platform is successfully set and i successfully copied the olca-app maven modules. 

However, i still get the following Plug-in Problem: 

Bundle 'org.eclipse.fx.ui.workbench3' cannot be resolved.

Does anyone meet this problem and help me to fix it?

Thank you,
Karima.

in openLCA by (190 points)
retagged by

1 Answer

0 votes
by (22.6k points)
An answer to this problem is available on GitHub

https://github.com/GreenDelta/olca-app/issues/68
by (190 points)
Hello,

Setting this new target platform fixes the plugin-problem org.eclipse.fx.ui.workbench3 . However, when launching openLCA.product, i get the following exception:

Unable to create class 'org.eclipse.ui.internal.e4.compatibility.CompatibilityEditor' from bundle '675'
org.eclipse.e4.core.di.InjectionException: java.lang.NoClassDefFoundError: javafx/scene/Parent
...