+1 vote
140 views
Hi team,

When I am starting OpenLCA and trying to open one of the databases to start modelling, 9 times out of 10, I will get an error like "Login timeout exceeded" or "failed to get the database version" and can't do anything. It is not the database as it sometimes works fine with no change.

Could you help identify the issue? I am sure it is not supposed to be so clunky.

Thanks.
in openLCA by (130 points)
by (9.8k points)
Thank you for reporting this issue. Does this happen with all databases (e.g. also when you create a new database) or only with a specific database (if yes, what kind of database is this)? Which operating system (Windows, macOS) and openLCA version do you use? If you could share the complete error message from the log file that would be helpful (Help > Open log file > scroll down to the latest error messages). Thanks!

1 Answer

0 votes
by (48.7k points)
Hi Marie,

do you have a very special installation environment maybe? So far in openLCA users do not really login, so there is also not a login timeout from openLCA?

Best wishes,

Andreas

- indeed, clunky, this is not our idea..
by (9.8k points)
In many database management systems you first have to login to get database connections. When you run the database in embedded mode this is often done with a default user. This is also happening in openLCA when you open a database and there is this "login" error coming from. It just fails to get this initial connection within a specific time.
...