0 votes
90 views
Hi. I tried to import the last openLCA LCIA method in JSON and i have the following error message

java.lang.UnsatisfiedLinkError: Can't load library: C:\Users\alogi\OneDrive\Escritorio\OpenLCA\openLCA\libgfortran-3.dll
     at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1827)
     at java.lang.Runtime.load0(Runtime.java:809)
     at java.lang.System.load(System.java:1086)
     at org.openlca.julia.Julia.loadFromDir(Julia.java:77)
     at org.openlca.app.App.getSolver(App.java:71)
     at org.openlca.app.rcp.RcpActivator.start(RcpActivator.java:68)
     at org.eclipse.osgi.internal.framework.BundleContextImpl$3.run(BundleContextImpl.java:842)
     at org.eclipse.osgi.internal.framework.BundleContextImpl$3.run(BundleContextImpl.java:1)
     at java.security.AccessController.doPrivileged(Native Method)
     at org.eclipse.osgi.internal.framework.BundleContextImpl.startActivator(BundleContextImpl.java:834)
     at org.eclipse.osgi.internal.framework.BundleContextImpl.start(BundleContextImpl.java:791)
     at org.eclipse.osgi.internal.framework.EquinoxBundle.startWorker0(EquinoxBundle.java:1013)
     at org.eclipse.osgi.internal.framework.EquinoxBundle$EquinoxModule.startWorker(EquinoxBundle.java:365)
     at org.eclipse.osgi.container.Module.doStart(Module.java:598)
     at org.eclipse.osgi.container.Module.start(Module.java:462)
     at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:493)
     at org.eclipse.osgi.internal.hooks.EclipseLazyStarter.postFindLocalClass(EclipseLazyStarter.java:117)
     at org.eclipse.osgi.internal.loader.classpath.ClasspathManager.findLocalClass(ClasspathManager.java:570)
     at org.eclipse.osgi.internal.loader.ModuleClassLoader.findLocalClass(ModuleClassLoader.java:330)
     at org.eclipse.osgi.internal.loader.BundleLoader.findLocalClass(BundleLoader.java:396)
     at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:474)
     at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:423)
     at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:415)
     at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:155)
     at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
     at org.eclipse.osgi.internal.framework.EquinoxBundle.loadClass(EquinoxBundle.java:620)
     at org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.createExecutableExtension(RegistryStrategyOSGI.java:196)
     at org.eclipse.core.internal.registry.ExtensionRegistry.createExecutableExtension(ExtensionRegistry.java:934)
     at org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension(ConfigurationElement.java:246)
     at org.eclipse.core.internal.registry.ConfigurationElementHandle.createExecutableExtension(ConfigurationElementHandle.java:63)
     at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:198)
     at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:137)
     at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:107)
     at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:400)
     at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:255)
     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
     at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
     at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
     at java.lang.reflect.Method.invoke(Method.java:498)
     at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:660)
     at org.eclipse.equinox.launcher.Main.basicRun(Main.java:597)
     at org.eclipse.equinox.launcher.Main.run(Main.java:1468)

I would really appreciate if you could help me.

Regards
in openLCA by (430 points)

1 Answer

0 votes
by (69k points)
selected by
 
Best answer
It seems you are running openLCA from a onedrive folder? I would try to run it locally.

Hope this helps, best wishes,

Andreas
by (69k points)
Still, you seem to have an "AccessDeniedException". Just download the zip version of openLCA, put it into your user directory somewhere, where you have write access, extract the archive, and run openLCA.
...