0 votes
40 views

After installing LCA CS, I'm having troubles to do the first commit.

I successfully configured the database in OpenLCA but I get an error when I try to do a commit. It failed when the progress bar is finished.

I tried with two different databases, repositories and groups on my PC and my laptop but I get the same error.

LCA CS is running in an LXC container based on Ubuntu 16.04 and installed following the installation guide (https://www.openlca.org/collaboration-server-installation-guide).

316140mainERRORorg.openlca.app.navigation.actions.cloud.CommitActionError during commit action
java.lang.reflect.InvocationTargetException: Server error, please contact your admin 
     at org.openlca.app.navigation.actions.cloud.CommitAction$Runner.lambda$3(CommitAction.java:154) 
     at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:122) 
    Caused by: org.openlca.cloud.util.WebRequests$WebRequestException: Server error, please contact your admin 
     at org.openlca.cloud.util.WebRequests.call(WebRequests.java:46) 
     at org.openlca.cloud.api.CommitInvocation.execute(CommitInvocation.java:71) 
     at org.openlca.cloud.api.RepositoryClient.lambda$commit$2(RepositoryClient.java:118) 
     at org.openlca.cloud.api.RepositoryClient.executeLoggedIn(RepositoryClient.java:380) 
     at org.openlca.cloud.api.RepositoryClient.commit(RepositoryClient.java:110) 
     at org.openlca.app.navigation.actions.cloud.CommitAction$Runner.lambda$3(CommitAction.java:146) 
     ... 1 more
in LCA Collaboration Server by (120 points)

1 Answer

0 votes
by (71.9k points)
Which version of openLCA are you using - for the latest version of the Collaboration Server, you should use openLCA 1.11 beta (latest builds, in the openLCA download page) - thank you.
by (120 points)
I tried again with a new group and a new repo in openLCA 1.11 beta and got the same error.
The testing procedure is the same each time : I create a new database in OpenLCA, configure it with a new repo and commit it. I got the error on my two computers running Ubuntu 18.04 and 20.04.
...