0 votes
35 views
I would like anyone to help me with how to speed up the calculations in openLCA.

openLCA calculations were slow in my old laptop despite increasing the memory to 8 GB. I recently purchased a new laptop (16 GB, i7) and increased the memory allocation to 16 GB and downloaded the some libraries to speed up the calculations (shown on the welcome screen).

However, the speed is still slow for many product systems when I use 'analyze' rather than 'quick' result. For example, I created a product system of 7 unit processes representing electricity generation of 7 countries. Ever after running for 15-20 mins, the calculations were not complete. I had to close openLCA and restart to stop the calculations.

Is openLCA this slow when doing 'analyze' feature? What am I doing wrong?

~ Sourabh
in openLCA by (610 points)

1 Answer

0 votes
by (74.1k points)
Hi Sourabh,

could be that you have a full harddisc, or that you do not have write access to the openLCA folder (so that the memory increase is not reflected in openLCA). The speed depends on the database of course. A calculation of 7 processes (without links to a background database) does not take long time (like: less than a minute).

Best wishes,

Andreas
by (610 points)
Thank you Andreas for your response. I have checked the space. It is fairly empty. The openLCA settings show higher memory allocation whenever I check it. Is it still possible that the openLCA cannot access it?

I am using ecoinvent 3.7 cutoff database.
...