0 votes
59 views

I am using Macbook pro (mid-2014) with OpenLCA 1.10.3 and Ecoinvent database. The configuration of my Mac are as following:

- Processor: 2.8 GHz Intel Core i7

- RAM 16 Gb

- Graphics: NDVI Geforce GT 750 M 2Gb

However, the calculation speed for unit processes in Ecoinvent extremely low compare to my Dell laptop (Intel Core i7 4600U 2.1 GHz, 16 Gb RAM). Two computer use the same version of OpenLCA and Ecoinvent 3.7. I do not know if it is caused by different OS or there is something wrong with OpenLCA on my Macbook? Thank you so much for your response!

PS: I attached the log file here. It seems that Julia library has been loaded.

imeThreadLevelCategoryMessage
0mainINFOorg.openlcaLog-level=INFO
2mainINFOorg.openlca.app.rcp.RcpActivatorstart openLCA 1.10.3, install location=/Applications/openLCA10.3.app/Contents/Eclipse, workspace=/Users/LDA/openLCA-data-1.4
8mainINFOorg.openlca.julia.JuliaTry to load Julia libs and bindings from /Applications/openLCA10.3.app/Contents/Eclipse
9mainINFOorg.openlca.julia.Julialoaded native library /Applications/openLCA10.3.app/Contents/Eclipse/libgcc_s.1.dylib
10mainINFOorg.openlca.julia.Julialoaded native library /Applications/openLCA10.3.app/Contents/Eclipse/libquadmath.0.dylib
10mainINFOorg.openlca.julia.Julialoaded native library /Applications/openLCA10.3.app/Contents/Eclipse/libgfortran.5.dylib
14mainINFOorg.openlca.julia.Julialoaded native library /Applications/openLCA10.3.app/Contents/Eclipse/libopenblas64_.0.3.5.dylib
14mainINFOorg.openlca.julia.Julialoaded native library /Applications/openLCA10.3.app/Contents/Eclipse/libolcar.dylib
14mainINFOorg.openlca.julia.JuliaMath libraries loaded without UMFPACK support.
15mainINFOorg.openlca.app.AppLoaded math libraries from /Applications/openLCA10.3.app/Contents/Eclipse
3064mainINFOorg.openlca.app.db.DatabaseListread database configurations from /Users/LDA/openLCA-data-1.4/databases.json
52905ModalContextINFOorg.openlca.core.database.derby.DerbyDatabaseinitialize database folder /Users/LDA/openLCA-data-1.4/databases/Ecoinvent_v3_7, create=false
20152432Framework stopINFOorg.openlca.app.rcp.RcpActivatorclose database
20152525Framework stopINFOorg.openlca.core.database.derby.DerbyDatabasedatabase closed
in openLCA by (120 points)
edited by

1 Answer

0 votes
by (59k points)
Hi, indeed, the numerical libraries depend on the operation system; you will maybe see a "cannot load Julia libraries" in the log file on the Mac, in which case the rather slow default libraries are used. You can try to fix this yourself, see please here: https://ask.openlca.org/1833/julia-libs-and-bindings-been-loaded-from-spring-tools-suite?show=1833#q1833.
by (120 points)
Thank you Andreas for your response. I have checked the log file and it seems the Julia library has been loaded. So is there any other cause that make the more powerful laptop slower in calculation with OpenLCA?
...