+1 vote
613 views

How to assign more memory to openLCA?

  • Possibly solves "java heap space" errors
  • Speeds up calculation time
in openLCA by (630 points)
edited by

2 Answers

+1 vote
by (5.2k points)
 
Best answer
If you run into a Java heap space error or get an OutOfMemory error you can increase the amount of allocated memory for openLCA in the preferences.

In the menu, select 'File -> Preferences', in the dialog select 'Configuration' and specify a new value for 'Maximum memory usage in MB', e.g. 4096 if you want to assign 4GB.

For the changes to apply, you will need to restart openLCA.

If you still run into problems, you can try to disable logging in the 'Logging' tab of the preferences, by setting Level to Info, unchecking the 'Show log console' box and closing the 'Console' tab afterwards.
+1 vote
by (22.7k points)
edited by

You can also do this via the openLCA.ini file in the openLCA installation folder.

To change this navigate to the folder in which the openLCA.exe file lies (make sure openLCA is closed). Open the file openLCA.ini in the same folder with a text editor and change the numbers between -Xmx and M to the amount of memory that you would like to allocate to openLCA.

-Xmx26624M
 

Save and start openLCA.

Backup your openLCA.ini before applying changes! Don't delete the original folder before you assured that the new folder has been set-up correctly (create a test database and check whether it shows up in the new folder)!

...