+1 vote
39 views
Hi,

Previously I worked with Open LCA 1.4 version in my laptop, now I installed openLCA 1.8 in my new desktop. I am trying to install ecoinvent database (that I worked in my 1.4 version) in 1.8 version. How can I load this zolka file (from 1.4 version) in my 1.8 version. Please let me know.
in openLCA by (130 points)
retagged by
by (20.3k points)
I've updated my answer.

1 Answer

+1 vote
by (20.3k points)
edited by
To avoid this type of problem, it is always recommended to use the latest version of openLCA. I think openLCA 1.8 is backwards compatible down to version 1.6 (not a hundred percent sure though). So what you have to do is to download previous versions of openLCA (https://sourceforge.net/projects/openlca/files/openlca_framework/) and open your databases which you wish to use in openLCA 1.8 with these versions and do the update incrementally. Maybe openLCA 1.6 and then 1.8 is enough but you may even have to do more intermediate steps. Make sure to backup your databases before upgrading the database scheme. We haven't had any reports about errors but still, it is always safer to keep backups (always e.g. in your Dropbox/Gdrive). I hope this helps.

_________________________

UPDATE: I have been informed that you should be able to directly update a 1.4 database to 1.8 so you might just try that without the incremental steps in-between. Still, backups of important data never harm.
by (130 points)
Thanks for the response. Could you please confirm that the way to back up my database- 1. right click on the database, 2. select export database as zolca file and 3. save in any location.  Actually I started to use OpenLCA on 2016, that time I installed version 1.4.2. Now I want to shift my database in my new desktop. So, If I install 1.4.2 in my new desktop, then how do I update my database version (that I worked using 1.4.2. ) to 1.8.  Please let me know how do I update it for 1.8.  I tried to update this database with 1.8, but it was not work.
by (20.3k points)
The right way to backup a database is to right-click on it and select 'backup'.
by (1.2k points)
Hi Jonas. Do I read this right that it means we could buy a dataset from nexus that is labelled for OLCA 1.4/1.5 and use it in 1.8? Specifically, I'm looking at the LC-inventories ones. That would be a really useful thing. Thanks :)
...