+1 vote
333 views
Is it possible to return to OpenLca 1.8 after updating to I.9?. This new versión has memory allocation problems and doesn't display General Information properly when running a product System.
in openLCA by (210 points)

1 Answer

+1 vote
by (12k points)
selected by
 
Best answer

Yes, you can. The 1.8 versions are still on the openLCA server: http://www.openlca.org/wp-content/uploads/2019/02/

The databases should be compatible between both versions so that it should be possible to use the same database with openLCA 1.8 and 1.9.

Could you also provide more information about these errors so that we can fix them in future versions:

  • Which database do you use and how big is the product system (information from   the statistics page)? In which kind of calculation do the memory problems occur that were not present in v1.8: analysis, MC simulation?
  • Could you attach a screenshot of the `General information` that are not properly displayed?
  • Which operating system do you use?

Thanks!

by (210 points)
Sorry, not generalizing, just referring to my Mac OS10.14, probably due to wrong settings. I cant allocate more memory. The message I receive is the same as question: "Problem with assigning memory allocation on OpenLCA 1.9 installed in MacBook" asked Aug 8 in openLCA by APratiwi.

General Information not displayed refers to this tab that doesn’t display any information in my Product System results. All the other tabs display complete info. Neither is the Project System name displayed in the superior tab. I have a screenshot but cant attach-it here I think?
by (12k points)
Regarding the memory settings: I created an issue to track this: https://github.com/GreenDelta/olca-app/issues/96. It should be possible to change the maximum heap memory in the `eclipse.ini` file as described in the issue.

Regarding the error in the `General information` page: does this only occur in openLCA 1.9 but not in openLCA 1.8? Do you get the same error with every product system? Is there an error message in log-file (Help > Log file)? Thanks for helping to solve these issues!
...