0 votes
16 views
Hey guys,

i don't know why but i can not export my results of the analyse in excell.

The log file shows:

Failed to load Julia libs from C:\Users\hagedorn\Documents\openLCA_win64_1.10.3_2020-06-24\openLCA

java.lang.UnsatisfiedLinkError: Can't load library: C:\Users\hagedorn\Documents\openLCA_win64_1.10.3_2020-06-24\openLCA\libgfortran-3.dll
     at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1827)
     at java.lang.Runtime.load0(Runtime.java:809)
     at java.lang.System.load(System.java:1086)
     at org.openlca.julia.Julia.loadFromDir(Julia.java:77)
     at org.openlca.app.App.getSolver(App.java:71)
     at org.openlca.app.rcp.RcpActivator.start(RcpActivator.java:68)
     at org.eclipse.osgi.internal.framework.BundleContextImpl$3.run(BundleContextImpl.java:842)
     at org.eclipse.osgi.internal.framework.BundleContextImpl$3.run(BundleContextImpl.java:1)
     at java.security.AccessController.doPrivileged(Native Method)
     at org.eclipse.osgi.internal.framework.BundleContextImpl.startActivator(BundleContextImpl.java:834)
     at org.eclipse.osgi.internal.framework.BundleContextImpl.start(BundleContextImpl.java:791)
     at org.eclipse.osgi.internal.framework.EquinoxBundle.startWorker0(EquinoxBundle.java:1013)
     at org.eclipse.osgi.internal.framework.EquinoxBundle$EquinoxModule.startWorker(EquinoxBundle.java:365)
     at org.eclipse.osgi.container.Module.doStart(Module.java:598)
     at org.eclipse.osgi.container.Module.start(Module.java:462)
     at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:493)
     at org.eclipse.osgi.internal.hooks.EclipseLazyStarter.postFindLocalClass(EclipseLazyStarter.java:117)
     at org.eclipse.osgi.internal.loader.classpath.ClasspathManager.findLocalClass(ClasspathManager.java:570)
     at org.eclipse.osgi.internal.loader.ModuleClassLoader.findLocalClass(ModuleClassLoader.java:330)
     at org.eclipse.osgi.internal.loader.BundleLoader.findLocalClass(BundleLoader.java:396)
     at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:474)
     at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:423)
     at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:415)
     at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:155)
     at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
     at org.eclipse.osgi.internal.framework.EquinoxBundle.loadClass(EquinoxBundle.java:620)
     at org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.createExecutableExtension(RegistryStrategyOSGI.java:196)
     at org.eclipse.core.internal.registry.ExtensionRegistry.createExecutableExtension(ExtensionRegistry.java:934)
     at org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension(ConfigurationElement.java:246)
     at org.eclipse.core.internal.registry.ConfigurationElementHandle.createExecutableExtension(ConfigurationElementHandle.java:63)
     at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:198)
     at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:137)
     at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:107)
     at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:400)
     at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:255)
     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
     at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
     at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
     at java.lang.reflect.Method.invoke(Method.java:498)
     at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:660)
     at org.eclipse.equinox.launcher.Main.basicRun(Main.java:597)
     at org.eclipse.equinox.launcher.Main.run(Main.java:1468)

Frustration Level 1000+ ^^. Any ideas?

Thanks

Tabea
in openLCA by (120 points)

1 Answer

0 votes
by (52.2k points)
this "failed to load libraries" happens if something is wrong with your installation, typically an admin installed openLCA and you are using it as non-admin and thus do not have access to the library location. Just use the zip archive version in these cases, download into your user directory, and unzip.
...