0 votes
59 views

I originally left this as comments in this thread, but since there was no response, I figured I'd make it a new question.

On one Mac I have OpenLCA 1.8 installed and the openlca.ini file is located directly inside the OpenLCA/Contents/MacOS/ folder. When I change the ini file, I can see the databases in the navigation pane when I open OpenLCA, but cannot open them with the error message, "Could not get the version from the database. Is this an openLCA database?". This may have been because they were copies of databases created on my other machine running 1.10.3

On my other Mac, I'm running openLCA 1.10.3. In this version, you have to open the openLCA application as a folder, then open the Contents "app" as a folder (i.e. to see package contents), then MacOS/openLCA.ini file is available. When I make the same changes to the ini file, OpenLCA still saves the databases to the default location.

I reinstalled/updated both machines to 1.10.3 and now this does not work on either machine. Any help?

in openLCA by (220 points)

1 Answer

+1 vote
by (160 points)
I've been testing it on my Mac and I think you need to make the changes into the `openLCA.app/Contents/Eclipse/eclipse.ini` file
by (160 points)
For me works adding the full path to the eclipse.ini file:
-olcaDataDir
/Users/miguel/GreenDelta/datatest

The path should exist in your PC and after making the changes you need to restart openLCA. If it doesn't work, maybe you can share the whole path of the eclipse.ini file that you are editing
...